Reply To: Continuation of Previous Thread Regarding New Features, Improvements, and Bugs

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Continuation of Previous Thread Regarding New Features, Improvements, and Bugs Reply To: Continuation of Previous Thread Regarding New Features, Improvements, and Bugs

#17125

Michael Samson
Participant

Hi Ernest,

Did you see my post above from a few days ago? No rush, just want to make sure you saw it…

I have an important issue to bring to your attention:

Filter to Use Parent (Linked) Page for Attachment Search Results Not Functioning with Index Table Method

If you recall you had provided me with a filter that is able to detect when an attachment has a parent (linked) page, and to then use that URL for the attachment search result. This is a feature that you said you're soon integrating into core.

I've been working here with my own development team to ensure that all of our attachments are properly linked to their parent post page in the media library. The idea being that the search will then see that linked post page and use it for the attachment link in search results.

During testing today I was having difficulty getting the filter to function. I was confused as to why it wasn't working because I had tested it when you first provided it to me. I figured out that the filter does not function if the attachments are set to use the index table method. As soon as I turned it back to the normal search method the filter worked, and the attachments used the linked post page.

I wanted to bring this issue to your attention so that when you build this feature into core (you said it would be in the next release), that it will function when attachments are using the index table.

…..

Just a note that the date filter bug is driving me crazy here with testing. What is happening is that the search cannot see any posts from today's date when the date filter is active. I have it set by default to display the last year of results. So anything posted on the current day is not being seen. This is troublesome especially when you're testing stuff on the site and need it to come up in search. Anyway, I look forward to this one being fixed too. 😉

~ Michael