Reply To: Author Name… Custom Field

#4355

Ernest Marcinko
Keymaster

Hi!

I think I understand. You want to use the correct display name of the users, not the “username”.

You will need to make a minor modification to the code for this to work.

Open up the wp-content/plugins/related-posts-pro/includes/related_content.class.php file.

You will need to change this string:

$wpdb->users.user_nicename as author,

… to this string:

$wpdb->users.display_name as author,

On the following lines: 89, 319, 546, 688, 721 and 746

Then go to the related posts pro options page and save the options without changing them. The author than should appear with the correct name.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)