Reply To: Uncaught SyntaxError: Unexpected token /

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Uncaught SyntaxError: Unexpected token / Reply To: Uncaught SyntaxError: Unexpected token /

#6941

Ernest Marcinko
Keymaster

Hi!

I see the following text in the “No results text” parameter:

<a href=/calificar>No se encontraron empresas. <strong>Agregala!</strong></a>

Unfortunately this is no longer possible to use HTML in the parameter there. It raised security concerns and I had to remove it.
Please remove HTML tags from the No results text option on the Layout Options -> Results layout panel.

You can still use that HTML though, by using result templating, which is much safer and update proof as well. Here is a quick tutorial link.

In your case you will have to first copy the wp-content/plugins/ajax-search-pro/includes/views/results/no-results.php file into a new folder named “asp” in your current theme folder. Then make the change on that copied file on line 30 to:

<a href=/calificar>No se encontraron empresas. <strong>Agregala!</strong></a>

That should fix the problem 🙂

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)