Reply To: Empty search with taxonomy filter not working properly

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Empty search with taxonomy filter not working properly Reply To: Empty search with taxonomy filter not working properly

#8636

ilariaroglieri
Participant

Thanks for your reply.
Unfortunately it is still not working as expected.
Let me explain better to you.
Let's say I want to see all products inside “archi”.
So, I select archi from the taxonomy dropdown and press enter without inserting any character in the search.
I expect the search to show me all results under “archi” category, but what I see is all the catalog.
I attached you the screenshots of the settings to double check they are what you suggested.
In the secondo image attached you can see the results it shows after selecting the term from the dropdown and typing enter: as you can see it returns the first categories just as i was selecting all the terms.
The third screenshot shows you what i see if i press “mostra più risultati” (show more results): i see exactly the whole catalog (as you can see also in the url, it's not returning the filter but a search on everything).
The fourth screenshot show you what I would like to see: the taxonomy archive for “archi”. I obtain this precise result if i type “archi” in the search and select the first result (the taxonomy term “archi”).
So do you think it is possible to fix this?
Thanks
Ilaria

Attachments:
You can't view files in this topic.