Trouble returning custom post type categories

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Trouble returning custom post type categories

This topic contains 10 replies, has 2 voices, and was last updated by  Numaphon 2 years, 5 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #9375

    Numaphon
    Participant

    Hi i am having trouble configuring the plugin to return results for combinations of Tags & Categories of Custom Post Type gd_place (Listings).

    I can return tag searches ok

    I cannot return post category searches…??

    #9376

    Numaphon
    Participant

    Actually Terms are not returning either sorry.

    #9377

    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the proper details.

    I’ve logged in and tried the “NEW NEW NEW” engine, which is configured correctly to search tags and categories for gd_place.

    I’m getting correct results:
    – Search for “central” gives me “central coast”: https://i.imgur.com/UmY9kV0.png
    – Search for “bris” gives me “brisbane”: https://i.imgur.com/IgPLYTP.png
    These are linking to the category page. Is this not correct?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9378

    Numaphon
    Participant

    Hmm… Not quite.

    Ok so the search “port stephens seafood” where Port Stephens is the Category and Seafood is the Tag.

    Only 3 results are returned, I presume because the phrases were found in the post content.

    I have many posts with that category & tag combination but they arent being returned…

    #9379

    Ernest Marcinko
    Keymaster

    I think I understand what you want.

    The keyword logic is set to “AND with exact keyword matches” on the General Options -> Behavior panel.
    In that case the “port stephens seafood” will not match Port Stephens as category and Seafood as tag – because they are two separate objects, treated separately in the database. In other words they are compared to the “port stephens seafood” phrase individually in the database, but because of the strict logic, they won’t match.

    There are however multiple solutions:

    1. Keeping the current logic, and using the index table engine
    The index table is a separated database table, which you can configure and generate. It basically makes a “word cloud” from posts and all related and selected fields into one object. It takes time to get it right, but it will give you extremely relevant results – as word occurence is also calculated. It’s heavily optimized, and very resource friendly.
    Index table engine in documentation
    Searching in categories/terms using Regular or Index table engine

    2. Changing the keyword logic to “OR” or “OR with exact keyword matches”. This will give you a wider set of results, but in exchange they are a bit less relevant.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9380

    Numaphon
    Participant

    Awesome, thanks 🙂

    #9382

    Numaphon
    Participant

    Ok so index is working well now.

    I am using [wpdreams_ajaxsearchpro id=2] MAIN Search.

    When I hit return it redirects me to the correct page but the results are different…??

    #9383

    Ernest Marcinko
    Keymaster

    Please check redirection and results override.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9384

    Numaphon
    Participant

    Ok great.
    But now it appends &asp_active=1 to the end of the url. How can I prevent this??

    #9385

    Ernest Marcinko
    Keymaster

    Unfortunately it’s not possible to prevent it yet. It’s required to pass the override attributes.

    There will be a different method implemented in an upcoming release, where it will be removed.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9386

    Numaphon
    Participant

    Ok cool thanks. Looking forward to that update 🙂

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.