Reply To: Conflict with W3 Total Cache

#10223

Ernest Marcinko
Keymaster

Hi!

I think I have found the problem.

At first I thought it was a memory issue, but something was eating up the memory, even if ajax search pro was disabled.

Then I checked your W3TC configuration, and the Object Cache was enabled, and to be used with “Disk” method. This option is however very very I/O intensive and causes a huge memory issue and slowdown. The same is true for the database cache: https://i.imgur.com/zhSLaa1.png

You don't need to enable Object cache, because PHP has a built in object cache method anyways 🙂
I also do not recommend using the database cache, unless you have the “memcached” method installed on your server.

I'm testing your site for about 10 minutes now, it seems to be a lot more responsive and faster, so I believe that was the problem. I've also left this statement in the wp-config.php file increasing the memory limit a bit:

ini_set('memory_limit','512M');

just to make sure everything runs smoothly.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)