Conflict with W3 Total Cache

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Conflict with W3 Total Cache

This topic contains 8 replies, has 2 voices, and was last updated by

 
Keymaster
5 years, 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #10202

    Participant

    There seems to be a conflict with W3 Total Cache.

    When both W3 Total Cache and Ajax Search Pro for WordPress are active, the admin back-end parameters disappear.

    Perhaps you know a way to tweak the settings so there is no conflict with this highly important and mainstream plugin.

    Thanks

    #10203

    Hi,

    I’m not aware of any issues with the two plugins unfortunately. It’s probably a specific configuration might be causing the problem. There is probably more information on the javascript error console.

    Can you please check the log-in url? It redirects me back to the main page, and the wp-login.php and wp-admin login pages are disabled. Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10206

    Participant
    You cannot access this content.
    #10207

    Hi!

    I’ve logged in and activated the plugin, but it’s not a javascript issue, since all the back-end fails.

    Unfortunately the error reporting must be disabled, as there is no error message there. I’m suspecting either something very simple, or maybe a memory limit issue. It looks very strange, never seen this problem before.

    However when I connected with FTP, I can only see an empty folder, I’m not able to see the site directory. Can you please check that?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10213

    Participant
    You cannot access this content.
    #10215

    Participant
    You cannot access this content.
    #10223

    Hi!

    I think I have found the problem.

    At first I thought it was a memory issue, but something was eating up the memory, even if ajax search pro was disabled.

    Then I checked your W3TC configuration, and the Object Cache was enabled, and to be used with “Disk” method. This option is however very very I/O intensive and causes a huge memory issue and slowdown. The same is true for the database cache: https://i.imgur.com/zhSLaa1.png

    You don’t need to enable Object cache, because PHP has a built in object cache method anyways 🙂
    I also do not recommend using the database cache, unless you have the “memcached” method installed on your server.

    I’m testing your site for about 10 minutes now, it seems to be a lot more responsive and faster, so I believe that was the problem. I’ve also left this statement in the wp-config.php file increasing the memory limit a bit:

    ini_set('memory_limit','512M');

    just to make sure everything runs smoothly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10227

    Participant

    Ernest, I appreciate you going above and beyond on this one. Now you have something else to put into your knowledgebase for people having the same problem.

    Thank you very much and I really like your search plugin! 🙂

    #10230

    You are very welcome!

    Thank you very much for the great review, I appreciate it a lot 🙂

    If you don’t mind, I will close this topic and mark it as resolved for now, feel free to open another one if you have other issues.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Conflict with W3 Total Cache’ is closed to new replies.