Reply To: Fatal error

#10881

Ernest Marcinko
Keymaster

Hi,

1. Because now you have the Primary ordering by relevance, not by date:
2. Yes, it is correct.
——
3. It's not going to work like that as you don't have the post type group ordering enabled anymore (because you wanted title matching elements first), so the search won't prioritize any post type over any other.

Just to clarify, the ordering is applied as following, from highest priority to lowest:

Post type ordering > Global Priority Options > Primary ordering > Secondary ordering

My recommendation is:
– Enable Post type ordering, and order the post types the way you want them to appear: https://i.imgur.com/pWl3XuY.png
– Set the Primary Ordering to Date descending and Secondary Ordering to Relevance Descending: https://i.imgur.com/Al9pwIS.png
You can experiment with this later, primary relevance might give you better results.
– On the General Options -> Limits panel enable the “Distribute the posts limit between each post type equally?” option and increase the post type limit to at least 36 or 45: https://i.imgur.com/TqJ91YI.png

This will display equal amount of results from each post type (you have 9 post types selected, so masimum 4 or 5 per post type), ordered by the post type ordering first, then global priority -> primary -> secodary ordering.
This option ensures, that even if there are many more matching elements on one of the post types, still other post type results are considered as well.

After reviewing your request, I believe this is the closest configuration to your requirements.
—-
The word found its PACHARAN , i just change to AND exact word matches and still there ..
Don't forget, that you have a secondary keyword logic “OR” enabled: https://i.imgur.com/kSI5cv1.png
If you only want the strict matches, you should turn it off.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)