Reply To: Fatal error


Ernest Marcinko


The index table would be much better for your case. But it's not properly configured.

For example, on the search settings panel you have the “news1” post type selected, but on the index table options it is not:
This means that no results will ever come up from the “news1” custom post type, because it's not indexed at all.

What exactly is wrong with the index table? I have tried a few phrases, but all I can see is much more relevant results for the index table.
“hotel pacha”
The index table results are much more relevant. The ordering is also set to primary relevance, so the results are correct, following the configuration. I've looked at the calculations regarding the relevance and keyword occurence, and it was also correct within the code. This follows the configuration as it should. Do you want it differently?

show first some agenda ibiza post

Them some more Agenda ibiza Post
but not show fiesta or restaurantes

Of course, because as I suggested earlier, if the post limit distribution is turned off, there is no guarantee that posts from every post type will fit into the limit.
Quote myself, previous post: On the <span class=”code”>General Options -> Limits</span> panel enable the “Distribute the posts limit between each post type equally?” option and increase the post type limit to at least 36 or 45:
The limit distribution makes sure that the limit is divided between post types and equal fractions are returned (if matches) for each post type.

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)