Reply To: Search Pro Stalls site periodically and does not give results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search Pro Stalls site periodically and does not give results Reply To: Search Pro Stalls site periodically and does not give results

#12287

Ernest Marcinko
Keymaster

Hi!

Thank you very much for the details, I've checked your configuration, it looks all right.

At first I suspected it might be a server related issue, but it's definitely not the case here. Everything is responsive as it should be, so I started to slowly change the configuration, until I found the reason. If I remove the product and the product_variation custom post type from the sources, it starts working as normal again.

I'm almost certainly sure it's not WooCommerce doing it by default, as I'm not able to re-create the issue on my test servers. I see you have a few WooCommerce related plugins there as well, so my guess is that when getting the product information or post processing, something somewhere cathes an infinite loop and the process is just terminated without result.

The server log only reveals that the processes were not responsive, but no other information is revealed. A possible way to resolve this is to go through the search code step by step, and hope to find a section which may affect this infinite loop to trigger – and perhaps find the relation to which plugin it points to (if any). For that I will however need temporary FTP access as well, to be able to make changes to the plugin code directly. I will then make a lot of test searches while changing the code, to see where it starts responding. Can you please add temporary FTP access as well? Thank you!

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)