Reply To: Index Table does not exist


Ernest Marcinko


Thank you for the proper details, it helps a lot.

I thought the issue was that the database tables are missing, but it's not the case. The plugin tried to get the tables, but they were not returned, even though the names were correct. Then I noticed, that in the wp-config.php file the table prefix is set to this:


But the database returns it in lower-case, like this:


I didn't want to touch that file, but I think that might have to be corrected, as I guess the actual database tables are created in lower case letters. (I just assume, because I can't check that)

I've fixed it by changing the table names variable to lower case in the search plugin files, but that's not a permanent solution, as some database engines are case sensitive in table names, so I can't implement it into the upcoming release.

I recommend checking the actual table names in the database, and if the prefix is s5zh1s2oed_ in lower case, then you should change that in the wp-config.php file as well, just to make sure to prevent case conflicts.

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)