Reply To: unexpected result


Ernest Marcinko


Thank you for the proper details!

1. The issue was that the filter operator was set incorrectly:
I've corrected that, now the results will respect the custom fields filter. This also caused the issue, when something was entered, no results were displayed. Now you should start seeing the results properly.

2. WordPress does not work like that, you cannot make a custom results page to redirect to, it's not possible. The only thing that is possible, is to display the default results page on a different URL (but it will not change it's layout). You can find a tutorial here:
Once a different permalink solution is created, you can enter this pattern to the custom URL section of the ajax search pro redirect option. I only recommend this, if you have a very good experience with symbolic links and templates.

To replace the search on the page, you could use the ajax search pro shortcodes in the Visual Composer editor:

1. Open the page, and change these elements:
2. Add the search shortcode:
3. ..and the results shortcode:
3. So it looks like this:

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)