Reply To: Gateway Timeout


Ernest Marcinko

Hi Brent,

My apologies for the late response. While I do work 7 days a week, the weekends I usually spend on development, as proper support can be time consuming. Please allow up to 48 hours (including only weekdays) to answer, as stated in the support terms, I get lots of responses every day, and I have to treat them equally 🙂

I rarely make exceptions, but I have looked at the source to see if the code is missing, but it looks like it's still there perfectly in tact (as far as I remember it). That actually is very good news, as I don't always keep track of customizations.

The issue was on the index table options panel, where the allowed statuses column was filled in incorrectly:
The entered values were:

public, private

..which is not correct. Post status 'public' does not exists in WordPress, it's correctly spelled 'publish'. Don't ask me why, it's not logical in my opinion, but it's something WordPress specific I cannot affect. It took me a good while to spot that mistake, but when I corrected it to

publish, private

..and re-created the index table, it seems to have solved the problem. If there were no other changes, it should be back to the state it was before.

For future refence, the custom code used in the functions.php file is this:

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)