Reply To: Lag with Flatsome and Sliders


Ernest Marcinko


This is a very intersting issue, and I possibly have two theories on why it might be lagging:

Theory 1 – Images?
I’m almost 100% certain, that this is the cause. After some in-depth investigation I’ve noticed, that some of the images are displayed as the original size, which might be causing a rendering problem with the browser. Luckily there are 2 very simple steps to optimize those image sizes:

– First, make sure to enable image cropping on the Cache settings submenu:
After this change, try the search again. It may already solve the problem.
– If not, then on the search instance options, General Options -> Image options panel, change the featured image source size to ‘thumbnail’:

These options will make sure to get the lowest possible available size, and crop it if needed. If the second suggestion results in less images, try the other sizes as well to find the sweet spot.

Theory 2 – Event-driven animation rendering?
This is less likely in my opinion, but should be considered as a possibility. My guess is that there is either a limitation within the browser to handle animations, or there is a script that attaches to animation handlers. I have not found any evidence to either of these after inspection, but it’s still possible.

The solution would be to turn off the custom scrollbar script, to see if that helps:

Let me know if any of these helped!

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)