Lag with Flatsome and Sliders

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Lag with Flatsome and Sliders

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 4 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14137
    SimoHDK
    SimoHDK
    Participant

    Hi Team,

    We recently purchased ASP, however we’ve having an issue with lag when using it with our Flatsome theme and multiple sliders. If you check out our home page, try run a search and you’ll see what I mean.

    Tried following the tutorial on speeding up search, however nothing has really worked.

    Cheers.

    #14144
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    This is a very intersting issue, and I possibly have two theories on why it might be lagging:

    Theory 1 – Images?
    I’m almost 100% certain, that this is the cause. After some in-depth investigation I’ve noticed, that some of the images are displayed as the original size, which might be causing a rendering problem with the browser. Luckily there are 2 very simple steps to optimize those image sizes:

    – First, make sure to enable image cropping on the Cache settings submenu: https://i.imgur.com/mBuDfyN.png
    After this change, try the search again. It may already solve the problem.
    – If not, then on the search instance options, General Options -> Image options panel, change the featured image source size to ‘thumbnail’: https://i.imgur.com/tfC3rKX.png

    These options will make sure to get the lowest possible available size, and crop it if needed. If the second suggestion results in less images, try the other sizes as well to find the sweet spot.

    Theory 2 – Event-driven animation rendering?
    This is less likely in my opinion, but should be considered as a possibility. My guess is that there is either a limitation within the browser to handle animations, or there is a script that attaches to animation handlers. I have not found any evidence to either of these after inspection, but it’s still possible.

    The solution would be to turn off the custom scrollbar script, to see if that helps: https://i.imgur.com/EilwlaP.png

    Let me know if any of these helped!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14146
    SimoHDK
    SimoHDK
    Participant

    Hi Ernest,

    Thanks for the help. The issue was resolved by enabling image cropping! Take a look for yourself.

    Whilst I have you – Does ASP have a nice results page that combines posts and products? As you can see we’re currently using the standard WooCommerce results page. Wondering if you have something similar, and how do we enable it?

    Cheers.

    #14155
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Unfortunately no, the results page is exclusively controlled by the theme you are using currently.

    I’m working on a possible solution to create a results page builder with a shortcode – but unfortunately it’s a very long way to go, as WordPress was built to use template files to display contents.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.