Reply To: Website extremely slow when plugin is activated

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Website extremely slow when plugin is activated Reply To: Website extremely slow when plugin is activated

#14287

Ernest Marcinko
Keymaster

Hi,

Thank you for the details, it helps me a lot!

I have conducted some tests, but it appears that the site is slow without even the plugin active.
It took me about 2 minutes to open the plugins menu on the back-end, even though this plugin was not activated. See this video please: https://www.youtube.com/watch?v=UlCIX6969Hk

Since Ajax Search Pro was not even activated, it is not executed nor loaded in any way. It looks like the issue is very likely caused by something else here. It can be affecting the search plugin performance as well, if the issue is with a resource, that is used by ajax search pro as well.

I would suggest checking the following things:
– Enable debug mode and error reporting in wp-config.php to see if there are any error messages.
– See if the site is allowed to open a connection to remote URLs. Long loading times on the back-end, especially on the plugins page is usually caused by failed connections to the plugin update servers. I'm almost positive this is the case.
Checking the allow_url_fopen php.ini variable might be a good start, also checking if CURL is correctly installed on the server.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)