Website extremely slow when plugin is activated

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Website extremely slow when plugin is activated

This topic contains 8 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 4 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14282
    mcilsamoa
    mcilsamoa
    Participant

    Hello,

    Really need your help urgently please.

    When the plugin is activated, entire website front-end and back-end is extremely slow.

    The site is being revamped, hence the temp URL

    Have deactivated the plugin for now so can work on other tasks.

    Using BeTheme

    Much appreciate your assistance urgently please.

    Kind Regards,
    Filisi

    • This topic was modified 4 years, 10 months ago by mcilsamoa mcilsamoa.
    Attachments:
    You must be logged in to view attached files.
    #14287
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you for the details, it helps me a lot!

    I have conducted some tests, but it appears that the site is slow without even the plugin active.
    It took me about 2 minutes to open the plugins menu on the back-end, even though this plugin was not activated. See this video please: https://www.youtube.com/watch?v=UlCIX6969Hk

    Since Ajax Search Pro was not even activated, it is not executed nor loaded in any way. It looks like the issue is very likely caused by something else here. It can be affecting the search plugin performance as well, if the issue is with a resource, that is used by ajax search pro as well.

    I would suggest checking the following things:
    – Enable debug mode and error reporting in wp-config.php to see if there are any error messages.
    – See if the site is allowed to open a connection to remote URLs. Long loading times on the back-end, especially on the plugins page is usually caused by failed connections to the plugin update servers. I’m almost positive this is the case.
    Checking the allow_url_fopen php.ini variable might be a good start, also checking if CURL is correctly installed on the server.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14304
    mcilsamoa
    mcilsamoa
    Participant

    Many thanks for the info Ernest, much appreciated.
    Indeed, its connection to remote URLs. Enabled debug mode and following shows up in plugins page

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /var/www/html/newsitemcil/wp-includes/update.php on line 320

    Consulting department techs re this.

    #14309
    mcilsamoa
    mcilsamoa
    Participant
    You cannot access this content.
    #14313
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I believe then this is going to be related to the automatic updater, which tries to get the most recent plugin version once a day. But since it was not able to successfully retrieve it, it tries again every time. I’m not sure why it is looping though, as there is a 2 second timeout set, which is also default for WordPress – and besides that, the remote blocking should do the trick here as well, as it uses the same built-in function as the others.

    Can you please add temporary FTP details as well? I would like to debug through the code to see where this is originating from exactly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14315
    mcilsamoa
    mcilsamoa
    Participant
    You cannot access this content.
    #14322
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Fine by me, but plase make sure to have a full site back-up of everything in that case. Editing files via plugins is dangerous, as one tiny syntax error could lead to a complete site failure with a fatal error, especially when touching wp-config.php or any other core files. I highly recommend using FTP or SFTP for development, it’s almost unavoidable to use.

    Anyways, I have found the issue. This line was incorrectly placed in the wp-config.php:

    define('WP_HTTP_BLOCK_EXTERNAL', true);

    ..any defines must be before this line:

    require_once(ABSPATH . 'wp-settings.php');

    This line always has to be the last active line of wp-config.php file 🙂 I have moved that define just after the WP_DEBUG, and it’s working now as expected.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14367
    mcilsamoa
    mcilsamoa
    Participant
    You cannot access this content.
    #14371
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.