Reply To: Ajax Search Pro spinning on clean WP install

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Search Pro spinning on clean WP install Reply To: Ajax Search Pro spinning on clean WP install


Ernest Marcinko


Thank you very much for the details, it helps me a lot. FTP unfortunately does not let me open anything, only locks me in an empty directory.

However I might have an idea what the issue is. Whenever I disable images, the search starts working again. I've looked through the source of that code part on my local server, and there is one function that might cause such issue, called mb_convert_encoding
I cannot confirm this, as I wanted change that line of code, but the FTP is not letting me.

The possible suspected cause is, that the multibyte functions might be disabled on the server. You might be able to enable them via the CPanel, or somewhere in the php.ini file. I highly recommend that, if possible, as lots of plugins require (or prefer) multibyte functions to work properly with strings.

If that is not possible, then can you please try the following solution:
– Open up the wp-content\plugins\ajax-search-pro\includes\functions\functions.php file on your server via an FTP editor
– Change it's contents with this:
– Save the file
In this file, the content parser checks if the upper mentioned function exists, before using it. If I was right, then this should solve the problem.

I hope this helps!

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)