Reply To: Relevance Search Issue

#8549

Ernest Marcinko
Keymaster

Hi!

It appears to me that your keyword logic is set to the default “OR” value, while I believe you need a more strict “AND” or “AND with exact keyword matches logic. You can change that on the General Options -> Behavior panel on the search instance options: https://i.imgur.com/JLBHHkA.png

A bit more information and explanation in the Search Logic and the Search logic explained section of the documentation.

Also, I see you have keywords below 3 characters (“q7”, “hp” etc..), whereas the default configuration of the index table ignores words below that threshold for generally better relevancy. However in your case this might cause the exact opposite. To change that go to the Index Table submenu on the Advanced Options panel: https://i.imgur.com/jzzicdV.png
Don't forget to create a new index table after the change.

After these changes, for even better relevancy, you can fine tune the weight values on the search instance options Relevance Options -> Index Table panel: https://i.imgur.com/yq9avKc.png
It's something to experiment with, but I usually suggest to increase the title relevance to 100 at first, to give the title keywords much better value. Then adjust the rest to this title value accordingly if needed.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)