Action when pressing the return button set to: Redirect to: Results page

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Action when pressing the return button set to: Redirect to: Results page

This topic contains 10 replies, has 2 voices, and was last updated by tjldesigns tjldesigns 5 years, 2 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #12551
    tjldesigns
    tjldesigns
    Participant

    Hello :),

    Just a quick one, you will see on this search form “General menu search” I have it set so in General options > “Logic and Behaviour” tab so that “Action when pressing the return button” it should “Redirect to: Results page” but if you try the search, if you look at the header of the website and lick the little search magnifying glass, you will see it reveals the search bar, if you type say “Law firm” it will show live results in the list, which is perfect, BUT when I hit the return button on my keyboard, it doesn’t do anything? Whereas at this point I would like it to take me to “http://taylorvinters.temporarywebsiteaddress.com/?s=Law%20firm”. Am I doing something wrong?

    Thanks so much for your help, amazing plugin as always,
    TJ

    #12552
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi TJ,

    It does redirect me to the results page when I press the return on my keybard. I’m guessing that the page might have been cached, and the search with the old configuration was displayed for you.

    Make sure to clear all levels of cache, including page, assets, varnish, cloudflare, browser etc.. After clearing the cache, and reloading, it should start working as expected.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12553
    tjldesigns
    tjldesigns
    Participant

    Hi Ernest,

    Thanks so much for getting back to me :).

    Sadly for me on Chrome – Incognito window also, when I hit Enter it doesn’t take me to the results page. And it doesn’t either if I try it in Firefox, also private window. It DOES however on Internet explorer. So strange?

    Many thanks,
    Tonya

    #12557
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Tonya,

    I’ve tried on multiple computers, but it works for me on all of them. Here is a video of a test in chrome incognito mode: https://youtu.be/ebmdnFlvQ9Q

    Make sure to clear all your browser cache, and reloading the page by hitting CTRL + SHIFT + R to also clear the asset cache. Also, if you use any browser extensions, they can also be a possible cause, it have happened a couple of times.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12559
    tjldesigns
    tjldesigns
    Participant

    Hello again Ernest,

    Firstly thank you so much for your amazing support, as always, it’s very much appreciated :).

    Back to this snag, I’ve re-tested that on my laptop and all is looking fine, I will tell my client to make sure they have done all this again! Argh! One thing I have tested from what they have also raised is that when you are on mobile (iphone / safari) or tablet (ipad / safari). When you type in “test” the live search starts to kick in, perfect, BUT if you tap the “SEARCH” button this also doesn’t take you to the results page. I just fully emptied all my cache on my ipad, and tried it, and sadly that is the case.

    I have checked the settings General options > Logic & Behavior, this is all set to Redirect to: Results page for both maginifier and the return key, which we know, and all great. I then look to the Mobile Behavior tab and both Magnifier and “Action when tapping the return button (search icon on virtual keyboard)” are set to “Same as on desktop” so all should be fine. As it doesn’t seem to be working though, I have also manually set it to “Redirect to: Results page” here too, just to make sure, saved it. Then cleared my full cache / website settings on my iPad / safari, and sadly still it doesn’t work. If I tap the magnifier it does, if I tap the search button, it doesn’t :(.

    I wonder if this is something relating to the problem my client is having on their desktop, maybe it’s a touchscreen computer, and maybe it’s something to do with the above?

    Thank you again,
    Tonya

    #12578
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Indeed, I was able to re-create the issue on my test environment as well. The search button on the keyboard does not redirect for some reason. I will investigate this in more detail, until then I’ve quickly put together a temporary solution.

    Place this code to the functions.php file in your active theme directory:

    It works on my test environments, I’m not sure how viable this bypass is though. It’s better than nothing I guess. I’m not looking forward to investigate the issue though. It’s 2017, and there is still no universal way of detecting mobile devices, nor properly handling events with javascript 🙁

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12599
    tjldesigns
    tjldesigns
    Participant
    You cannot access this content.
    #12601
    tjldesigns
    tjldesigns
    Participant
    You cannot access this content.
    #12603
    tjldesigns
    tjldesigns
    Participant
    You cannot access this content.
    #12607
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Yes, that explains it. For very old IE versions (IE<=9) the plugin simply outputs the default WordPress core search box (or nothing) instead as a fallback.The compatibility mode on IE edge is also a problematic feautre, as it's not the same as viewing it with previous original IE versions. I had to set up multiple virtual machines with pre-installed windows versions to be able to test. I believe about a year ago, when Microsoft finally discontinued IE 10, 9 and older, we could officially move on and simply use a fallback method, except for IE 10, which is still capable of displaying most features of the plugin just fine.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12718
    tjldesigns
    tjldesigns
    Participant
    You cannot access this content.
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.