Additional Search words not working

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Additional Search words not working

This topic contains 6 replies, has 2 voices, and was last updated by

 
Keymaster
1 year, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #27212

    Participant

    Hi,

    I am trying to add additional search words to the post; however it is asking to separate with space and I am not sure how to add double search words together. I wanted to add Tier 2 as a search word and tried Tier+2, Tier_2, Tier-2, Tier2 etc. None of that is working. As space is the separation, when I put Tier 2, it is recognising as 2 words.

    https://prnt.sc/sema3y

    Please advise.

    Regards
    Adarsh

    #27218

    Hi Adarsh,

    If you type in “Tier 2” there it will be always treated as two separate words. If that phrase was occuring in any field (title, content etc..) it is still treated as two spearate words. You can simply type in “Tier 2” in there, it is perfectly fine.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #27231

    Participant

    Hi,

    In that case, if I want to add more words, how do I separate them ? it says to separate by space. SO lets say I want to add ‘Tier 2’ and ‘Tier 2 ICT’
    Are you saying we can add as Tier 2 Tier 2 ICT ?

    Words Added: https://prnt.sc/sep5ft
    Also on headings and content: https://prnt.sc/sep66u
    Not showing on results: https://prnt.sc/sep66u

    Regards
    Adarsh

    #27232

    Hi Adarsh,

    Adding the same words twice is redundant, in that case adding only “Tier 2 ICT” is sufficient.
    Also, by default single character words are not considered for matches, you can change that here: https://i.imgur.com/lUlKXIc.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #27247

    Participant
    You cannot access this content.
    #27306

    Participant
    You cannot access this content.
    #27316

    Hi,

    I’m sorry for the late response, somehow I didn’t get a notification about your reply.

    I have looked up your configuration, and made a few quick changes, that I think will resolve the issue:
    1. I have enabled the index table engine, it is overall better for looking individual keywords: https://i.imgur.com/xEz3RrT.png
    2. I have changed the search logic: https://i.imgur.com/5cbkM69.png
    This logic will prefer whole word matches first, then random/fuzzy matches

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.