After latest update plugin not searching

Home Forums Product Support Forums Ajax Search Pro for WordPress Support After latest update plugin not searching

This topic contains 10 replies, has 2 voices, and was last updated by veedubtransporters veedubtransporters 6 years ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #9199
    veedubtransporters
    veedubtransporters
    Participant

    Good morning,

    We have been using your plugin, Ajax Search Pro, for a couple of months now and it has been working fine.

    I noticed that an update was available, so I went ahead and installed the latest version (4.9.1) after the update our search bars aren’t doing anything at all, when I type in the name of a product nothing happens (before a dropdown would appear with products relevant to the search term), when I press ‘enter’ it doesn’t search for the term and clicking on the magnifying glass also doesn’t search.

    The settings seemed fine and unchanged from what was there before hand, but I opened them and saved them again without making changes, but it is still the same. We haven’t installed or updated any new plugins to the website since updating. No cimpatability errors have been found either.

    I would also like to add that when in settings panels for both of our search bars, they work perfectly in the preview mode

    Kind regards,
    Tom.

    #9201
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve checked the URL and did a test search, but it’s working fine for me: https://i.imgur.com/5AaMOhQ.png

    Make sure to clear your browser, site and CDN cache – it’s a possible source for these types of issues. Let me know if something changes.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9207
    veedubtransporters
    veedubtransporters
    Participant

    Hello,

    I have had the CDN flushed on the website and it is working correctly now.

    The only difference I have noticed, is when I press ‘more results’ instead of it going to a page listing all results for that search (it used to do that before) it now adds the x amount or the remaining results to the end of the list. Is there any way of getting it back to how it was?

    Kind regards,
    Tom.

    #9208
    veedubtransporters
    veedubtransporters
    Participant

    Hello,

    I have found where I need to go to make it go to the correct page. However when I use ?s={phrase}&post_type=product it doesn’t redirect to a page listing the search results. Instead it puts in a weird URL that looks like this http://www.veedubtransporters.co.uk/shop/?s=wheels&np_asid=1&np_asp_data=qtranslate_lang=0&set_intitle=None&set_incontent=None&set_inexcerpt=None&customset%5B%5D=product&woof_parse_query=1

    The above link URL goes to our shop homepage. Any idea what could be causing this?

    Kind regards,
    Tom.

    #9255
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    The url is changed, because probably the “GET” method is selected on the override options: https://i.imgur.com/em2Qb01.png

    Try changing that to “POST”, it will get rid off the long URL, and use sessions instead.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9260
    veedubtransporters
    veedubtransporters
    Participant

    Hello,

    That hasn’t helped. I have tried different combinations with that setting. Having it ON or OFF and method POST or GET but either way it still doesn’t work.

    Is it possible that woocommerce have updated the URL for this kind of thing? Like I said, we haven’t changed anything except for updating the plugin.

    Kind regards,
    Tom.

    #9270
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve tried to replicate the issue on test environments with the latest WooCommerce, but no luck, it’s working for me.

    What I’ve noticed, is that if I try to open an url on your server like:

    http://www.veedubtransporters.co.uk/shop/?s=wheels&post_type=product

    it immediately gets redirected to:

    http://www.veedubtransporters.co.uk/shop/?s=wheels&woof_parse_query=1

    In this case the ajax search plugin is not triggered, but something is cathing and redirecting the page whenever the post_type query argument is present. This does not happen if the post_type argument is missing, for example:

    http://www.veedubtransporters.co.uk/shop/?s=wheels

    doesn’t redirect.

    Do you think this is related to the problem? I don’t think it’s woocommerce is doing this redirection. Or is this supposed to happen?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9272
    veedubtransporters
    veedubtransporters
    Participant

    Hello Ernesto,

    Yes, I think that this is related to the issue and is causing our problem, I have never noticed that code before. Now I need to figure out what is stopping ajax search from working properly, and then replacing ‘post_type=product’ with ‘woof_parse_query=1’. If it’s not woocommerce that’s doing this, it might be a plugin that has recently updated.

    Any ideas what would use ‘woof_parse_query’? I am not asking for you to look into this (as it doesn’t look like a problem with your plugin) but just if you have any ideas at all.

    Kind regards,
    Tom.

    #9275
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I gladly help if I can. The closest thing I could find:

    http://masterpressplugin.com/docs/developer/methods/woof-parse-query

    I don’t know if this is indeed related, but it looks oddly similar.
    In case you have this plugin, then I guess it’s worth trying to disable it temporarily, to see if that fixes the problem.
    If yes, then enable it again, and looking through the options. There might be a way to turn off that redirection.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9277
    veedubtransporters
    veedubtransporters
    Participant

    Hello,

    I have taken a look and I have traced woof parse_query to the plugin – WOOF – WooCommerce Products Filter – which when I disable removes ‘woof_parse_query=1’ from the search URL and displays results. They’re not displayed exactly how they were before, but at least now it goes to where we need it to.

    I don’t know if there is an incompatibility between both your plugin and WooCommerce Products Filter, but I thought I’d let you know what I have been able to find so far. If I manage to get it to work how it was before, I’ll let you know.

    Kind regards,
    Tom.

    #9278
    veedubtransporters
    veedubtransporters
    Participant

    Hello,

    It is this plugin – http://codecanyon.net/item/woocommerce-product-filter/8514038 that we are using, not the one I stated above. If I deactivate that plugin and remove the default shop page, it displays the results how it used to (see 1.png)

    If I leave the plugin deactivated and set our default homepage, the results are shown a little bit messed up http://www.veedubtransporters.co.uk/?s=wheels&post_type=product&asp_active=1 (see 2.png and 3.png)

    And then if I have the plugin active and either a default shop page set or not, the first issue that I contacted you about happens.

    Kind regards,
    Tom.

    Attachments:
    You must be logged in to view attached files.
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.