Ajax Pro search profiles not customisable

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Pro search profiles not customisable

This topic contains 6 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 month, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #38880
    smhenley1
    smhenley1
    Participant

    Hi,

    I have used Ajax Lite for over a year and finally paid for the Pro yesterday but Ajax Pro does not seem to be customisable upon creating a search profile. It only uses the default settings. E.g. I want to be able to change settings Layout Options and Autocomplete suggestions etc, change themes and colours etc etc. When pressing “Save all tabs” nothing changes even though it appears to go through the process of updating.

    I have not disabled all other plugins but a couple that I know that have caused me problems in the past like “WP Custom Admin Interface.”
    I have not changed the theme.
    No error messages. Compatibility check says “No compatibility errors found”

    Regards
    Steve Henley

    #38891
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Steve,

    Thank you for the details, it helps us a lo!

    If the changes are not populating to the front-end of your site – that is usually because of heavy cache. If you are using any caching/speed plugins, make sure to clear all layers of cache – including page, minify, asset, browser, CDN, cloudflare etc.. That will resolve the issue.
    Turning off the cache while making changes to the website is usually the best way to avoid these issues. Once the styling is ready, the cache can be turned back on.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #38901
    smhenley1
    smhenley1
    Participant

    Hi Ernest,

    I have done as you suggested but the problem still persists.

    My WordPress developer, Martin De Lange of catim.co is stumped. He says as follows:

    So the symptoms:
    Cannot set the settings on the style page…one can change it however it reverts immediately after saving to none selected.
    I can import the instances with styling from my catim site and it will stick ok

    What I did to debug:
    Worked through below that they should have passed rather than their poor reply.
    https://documentation.ajaxsearchpro.com/performance-tuning/visual-performance#force-inline-styles-option
    The CSS folder is set to 777….eventually I set the Ajax root folder to 777
    Main Cache plugin is disabled
    Disabled all the cache features inside Ajax
    Clear all the install data of Ajax plugin
    Reinstall of Ajax plugin
    Checked database for problems
    My catim.co has same settings and works perfectly as expected
    Tried different theme..I have same theme on catim and it works.
    Plugins and WordPress is updated (V6.01), PHP is updated
    Tried different browsers with defaulted state

    So the symptom again is CSS settings are changed but reverts back to none selected. Other settings are fine. Although this is typically a write permission error the CSS folder is set to 777.

    Regards
    Steve

    #38914
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Steve,

    Okay, this sounds like something is wrong on the server side. If the options on the back-end does not save, or only save partially, it could mean, that the php max_input_vars directive is set to a very low initial number. Please check the php.ini file for the max_input_vars directive, and change it to 3000 – that will be more than sufficient to pass on the post variables.
    The plugin has a detection mechanism to check this directive, but php may not neccesarily report the correct local value of the directives.

    I tried to log-in to check the issue directly, and debug it if needed, but I can’t access the site back-end – I have tried the /wp-admin/ as well as the wp-login.php access points, but they are not allowed. Can you please send me the back-end url?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #38930
    smhenley1
    smhenley1
    Participant
    You cannot access this content.
    #38933
    smhenley1
    smhenley1
    Participant

    Ok that change to max_input_vars directive to 3000 worked.

    Thanks so much.

    How do I include a filter for comments on my search bar?

    Regards
    Steve

    #38956
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Steve,

    That sounds great. You can create use the content type filter to show/hide comments: https://i.imgur.com/umR62eD.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.