Ajax Search Pro category filters issue

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Search Pro category filters issue

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 3 years, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #20113
    auroraservicedesk
    auroraservicedesk
    Participant

    hamk.aurorads.pro is QA/Testing env for http://www.hamk.fi

    Implementation of search: https://hamk.aurorads.pro/koulutushakukone
    ID 12

    Search finds AMK tutkinto and DP Bachelor tutkinto -custom post types with keyword search.
    Category filters does not work. E.g. Language does not work.

    With DB Bachelor Kieli (language) category Englanti (english) is selected but filter does not find these posts. The corresponding (same name as the post type) category is not even selectable on filters.
    If Kieli -category is unset on post, it is shown when Englanti is selected on search. If Englanti is set it is not shown on search with filter selected.

    DB Bachelor and AMK tutkinto are similar post types. They use same custom taxonomies. DB Bachelor is for english language and AMK tutkinto is for finnish.

    The whole idea is to search/filter Finnish and English content at the same time.

    I agree the configuration is a bit messy. However The reason for non working filters are not so obvious to us.

    I’ll be happy to give more info if needed.

    #20121
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you for all the details, I think I understand what the issue is, I am sorry if I missed something.

    If I get it correctly, you want to display only the items from the selected language, when one of the checkboxes (or both) are selected, but the problem is, that you see other posts as well, that does not belong to that filter. And this happens to any of the filters.
    If so, then you are looking to disable this option right here: https://i.imgur.com/TfyDMn0.png

    Basically what this does is, that when any of the filters is selected, then nothing else is displayed, only items that have any connection with that taxonomy. For example, if ‘English’ is selected, then anything that is tagged with ‘English’ will be returned, but nothing, that has no language assigned.

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #20147
    auroraservicedesk
    auroraservicedesk
    Participant
    You cannot access this content.
    #20153
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I believe there might be an issue with the ‘kieli’ language taxonomy. If you check the taxonomy for all languages, you will find that there are two separate ‘Englanti’ terms there: https://i.imgur.com/NUiM4rQ.png
    I believe it depends on which language you use, the second one is probably for english.
    WPML automatically returns terms on the current language. Maybe there is a way to use it to assign cross-language terms for multiple languages.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #20155
    auroraservicedesk
    auroraservicedesk
    Participant
    You cannot access this content.
    #20157
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Kari,

    As far as I know, translating the taxonomies does the same as translating the posts in WMPL – it creates a separate taxonomy term for each translation. So basically the original and the translation are separate terms, not the same. The search requests them with the default get_terms(..) function, and that always returns the corresponding terms for the corresponding language, so it works with them.
    Maybe this is best left untranslated, or perhaps the translation and the original term should be assigned to the posts as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.