Ajax Search Pro issue with WPML

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Search Pro issue with WPML

This topic contains 4 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 week, 5 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #40999
    artware
    artware
    Participant

    Hello,

    In my website I use WPML to translate it. But the search isnt working properly.
    For example if you go to the website https://ekahellas.com/ and at the top-right click the search and you write “Extremis” you will see some results (before pressing Enter).

    But if you go to the Greek language here: https://ekahellas.com/el/
    and you search again for Extremis, it will say No results.

    If you press Enter, you will see correct results, but prior to that, it shows no results.
    Is that Ajax search pro issue or WPML issue?

    #41008
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    By default ajax search pro will only display resuls from the currently active language (anything that is translated). If you want to display everything regardless of the language, then you can turn that off here: https://i.imgur.com/NkHSN9u.png

    That should do the trick!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #41010
    artware
    artware
    Participant

    Hmm, now when I write Extremis, I cannot see any results from either langugage (before I could see results in the EN language).

    Also, when I write something else, I can see results but they are in the GR language (the result URLs) even though I am searching from the EN version. I think the WPML option should remain active.

    My main problem is when I write Extremis in EN i see Ajax results, but whille on GR version, I don’t see.

    Just to clarify, Extremis is a tag on a custom post type. It is also a taxonomy name that these custom posts types belong to.

    It is just strange that Ajax results show items but only while on EN language, not on GR.

    #41011
    artware
    artware
    Participant

    It is okay I fixed it by creating a New Index. So far I was using the “Continue existing index” as I didnt really understood the difference between these two.

    Thanks for the help though 🙂

    #41012
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You are welcome 🙂 I am happy it is sorted now.

    If you don’t mind, I will close this topic soon and mark it as resolved, feel free to open another one if you have other questions or issues.

    If you like the plugin and have not rated already, feel free to leave a rating on your codecanyon downloads page and on the wordpress plugin repository, it’s greatly appreciated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.