Ajax Search Pro not working when used to replace default theme search

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Search Pro not working when used to replace default theme search

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
3 years, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #16575

    Participant

    After replacing the default theme search with Ajax Search Pro (Theme Search Bar Replace) nothing happens when doing a search via the search Icon in the navigation bar.

    I don’t get any error messages. I cannot check my error log files for error messages.

    When using Ajax Search Pro shortcode on a new page it works fine: https://www.egypttoursplus.com/test-search/

    Can you please help me out? (Note that I have disabled the Theme Search Bar Replace again).

    #16590

    Hi!

    Thank you very much for the proper details, it helps me a lot 🙂 I managed to fix the issue.

    The problem was, that the menu copies the search contents when it is clicked for the first time, causing all the event handlers to detach – meaning that plugin won’t work. It is probably designed for the built-in search box mainly.

    Luckily there is an option on the plugin back-end, which tries to detect these changes, and then re-init the search function, I have enabled this for you here: https://i.imgur.com/4HtybZG.png

    It should be working correctly now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.