An error occured. Please contact website administrator when using backspace

Home Forums Product Support Forums Ajax Search Pro for WordPress Support An error occured. Please contact website administrator when using backspace

This topic contains 4 replies, has 2 voices, and was last updated by

 
Participant
1 year, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25713

    Participant

    i add a ajax search as widget on the left, however when i try to search something, a orange banner with: “An error occured. Please contact website administrator” will occur on top, esp. when i press backspace before the result is load.

    also is there any way to speed up the search even more? i have limited the search and index to one custom field only, with index table it should give result within a second? yet sometimes it loaded a bit slow

    thanks in advance

    EDIT: after more testing, only happen when set to live search, if i turn off live search, only search after hit enter this won’t happen

    • This topic was modified 1 year, 11 months ago by  mechcalvin21.
    #25722

    Hi!

    Can you please link me to a page where the plugin is present and I can check the issue? I am not sure what might be the cause yet.

    The search performance mostly depends on the server performance, but there are things you can do of course to speed it up. This documentation should help you out.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25723

    Participant

    https://homeplusdemo.mechcalvin.com/properties/ you can see the ajax search on the left (i disabled the plugin and live search before), if you type anything fast and do backspace the error will occur

    i will try the suggestion

    #25731

    Hi,

    Thanks! Unfortunately that is not related to this plugin. I think another script is watching the ajax requests, and when hitting the backspace the search aborts the previous request before starting a new one – and that other scripts falsely detects that as an error.

    It looks like it’s coming from the theme, from this file, on lines 684-705

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25734

    Participant

    thanks, i will check that, but for the time being, i have disabled live search to stop this error and it is success on desktop, however when i use mobile, even i disable all live search, mobile behavior Trigger search when typing on mobile keyboard? to No, yet it still do live search result in errors

    https://homeplusdemo.mechcalvin.com/properties/ same link and i have put the search on top of the mobile view.

    EDIT: it just cache problem, works now

    • This reply was modified 1 year, 11 months ago by  mechcalvin21.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.