And logic not working correctly

Home Forums Product Support Forums Ajax Search Pro for WordPress Support And logic not working correctly

This topic contains 2 replies, has 2 voices, and was last updated by rdcrew3392 rdcrew3392 7 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4713
    rdcrew3392
    rdcrew3392
    Participant

    Hi,

    I’m using this plugin on one of my adult sites, so didn’t provide my URL. However if you want it I can give it to you.

    The issue I am having is that in the setting I have checked to use AND logic, however the front end results are behaving like the OR logic.

    If for example if I had two pages:

    /nature
    /nature-animals

    Using the AND logic, you would expect the /nature-animals page to show if I typed ‘nature animals’ however BOTH of the URL’s show.

    Have I got the wrong idea?

    Ricky

    #4714
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    There are two explanations I can see here:

    1. Either one of the selected fields (title, content, excerpt etc..) has both words (or parts of these words) “nature” and “animals” in it. I’m suspecting the post content, which is usually longer than the title or other fields.

    2. The plugin is functioning in fulltext mode. There is a known bug, where in some cases the plugin uses the fulltext mode even though it’s deactivated. In fulltext mode is no such thing as search logic, as it’s a natural matching database algorithm.
    To get rid off this, go to the Fulltext search Settings submenu and make sure the Use fulltext search when possible option is turned OFF (https://i.imgur.com/IYO5eUx.png). Then save the settings even if you haven’t changed anything to make sure the values are synced to the database.

    If you see an error message like “MyIsam tables are disabled, fulltext search not available!” when going to the fulltext options page, then the fulltext search definitely not the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4818
    rdcrew3392
    rdcrew3392
    Participant

    Full text mode was turned off, but like you said I just saved the page anyway and it seems to have fixed it!

    Thanks for the help 🙂

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.