ASP doesn't work with Elementor Pro Popups

Home Forums Product Support Forums Ajax Search Pro for WordPress Support ASP doesn't work with Elementor Pro Popups

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
2 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #24308

    Participant

    Hello

    Bought this module under the assumption that it works with Elementor Pro as advertised, but apparently with Elementor Popups doesn’t work seem to work.

    Why do I would need the search into a Elementor Popup, well that’s the only way to create a “mega menu for mobile” as described here. https://elementor.com/blog/responsive-menu-popups/

    My env. is on localhost so there’s no link to share, but what I did was I installed your module, created a search, on desktop looks great with the compact style, then I duplicated the search box deactivated the compact style and then added into the pop-up, and there no live search, no console errors.

    Created a new “fresh” as default and added it to the Popup and still the same, no live search.

    How can I solve this ?

    Regards.

    #24314

    Hi,

    If there are no errors on the log and the search styling and layout is okay, then I suspect that elementor may “clone”/”copy” the search element into the pop-up container, that may explain this issue. It is a very bad programming practice, as cloning DOM nodes detaches event handlers, causing a non-responsive item.

    There is a bypass option within the plugin, please try activting it here: https://i.imgur.com/lGcpC0B.png
    If the issue is the element detachment, then this will very likely resolve the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.