Avatar and Autoload issue with live migration

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Avatar and Autoload issue with live migration

This topic contains 5 replies, has 2 voices, and was last updated by

 
Keymaster
3 years, 9 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17331

    Participant

    SEE SECOND POST in same thread

    We have migrated our searches to the live environment so included new FTP login. We have 2 issues that are of concern.
    1) The avatar images are no longer showing up. We did copy the custom code your wrote (https://wp-dreams.com/forums/topic/get_avatar-support/) To see what I mean, try this link https://geniecast.com/?s=yoram

    2) On the searches by taxonomy, is it possible to autopopulate the main page with a preselected category, but then when someone checks off a new category, that search “disappears” and all new items come in? Right now it seems that whatever we set up in Search Box Layout -> Autopopulate is affecting the results selected on left hand side of page. We want the results that show up when the page loads NOT to affect any future selections. Here is an example link: https://geniecast.com/category-test/

    • This topic was modified 3 years, 9 months ago by  riegerjm.
    #17342

    Participant

    UPDATE:
    We resolved issue #1

    For issue #2 – what we need to be able to do is pass a category into the search page and have that category auto-populate it with initial results. But then, when a new category is checked, we do not want the auto-populated results to limit the search with the new selections – but rather to return all the items for the newly select category.

    Please see this link: https://geniecast.com/category-test/?wpv-category=personal-development

    Rather than pass in the search term “personal development” – we would rather have it auto populate using that category from our taxonomy. Then, if a person checks off another box on the left, those OLD results will go away and the NEW ones will load. If you try now and check off K-12, you will see there are only 2 results – but there should be 6 total. I think the auto population term is limiting the result set.

    • This reply was modified 3 years, 9 months ago by  riegerjm.
    • This reply was modified 3 years, 9 months ago by  riegerjm.
    #17349

    Hi,

    #2 – While this falls under customization requests, I might be able to suggest a possible solution. This will work only if the auto populate is enabled to a search phrase (does not matter what phrase, leave it empty).

    The first section of this code will overwrite the auto populate phrase, if the wpv-category query variable is set. Another possible solution would be to auto-check the category based on this variable, but it is much more complicated – as the category ID would have to be resolved first, then a custom script must auto-check the desired value. I am not sure if that is even possible to be honest.

    The second part will make sure to clear that phrase, whenever anything is clicked on the settings box.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #17356

    Participant

    Thank you very much! Very clever solution! We were able to force it to select only categories by limiting the search!

    • This reply was modified 3 years, 9 months ago by  riegerjm.
    #17358

    Participant

    It seems when we added the custom filter, that the price filter on the page stopped working. Could this be due to the new code?

    https://geniecast.com/program-search/?wpv-category=personal-development

    #17366

    Hi!

    I don’t think it should affect that, at least I don’t know why it would. Have you tried removing the code temporarily and test it again? If it’s not working without the code either, then it’s probably something else.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.