Blog Multisite section doesn't appear any Blog

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Blog Multisite section doesn't appear any Blog

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 7 years, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2918
    Nico González
    Nico González
    Participant

    Hi! I just buy this plugin for my WordPress Multisite and I found two issues to ask you:

    1 – In the Blog Multisite section doesn’t appear any Blog. Why?

    2 – When I search something, The query is very low speed. Why?

    How can I fix this problem?

    Can I set the speed of the query in some php file?

    Thanks!

    This is the admin url: http://inhouse.com.uy/panel/

    server: 192.185.72.133

    #2919
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    1. It’s probably because the blogs are flagged differently for the parser. There is a very quick solution, that helped someone last week. In the next version this is changed of course:

    i) Open up the wp-content/plugins/ajax-search-pro/functions.php and go to line 245, where you should see this:

    
    $blogs = $wpdb->get_results( $wpdb->prepare("SELECT blog_id, domain, path FROM $wpdb->blogs WHERE site_id = %d AND public = '1' AND archived = '0' AND mature = '0' AND spam = '0' AND deleted = '0' ORDER BY registered DESC", $wpdb->siteid), ARRAY_A );
    

    ii) Modify that line to:

    
    $blogs = $wpdb->get_results( $wpdb->prepare("SELECT blog_id, domain, path FROM $wpdb->blogs WHERE site_id = %d ORDER BY registered DESC", $wpdb->siteid), ARRAY_A );
    

    2. The search speed highly depends on the database size and server speed. So if you have a larger database, then the best performance tweaks for the search configuration are the following:

    – Disable the search in terms – the terms table can be insanely big if you have thousands of posts: (General Options -> Sources https://i.imgur.com/VCIlQ6e.png)

    – Disable the search in content and excerpt – if you have long content strings, it may take a while for the database to respond. (General Options -> Sources https://i.imgur.com/E2ESzWB.png)

    – Disable the relevance ordering – this is highly related to the previous two. In some cases it helps a lot, in some cases it has no effect, but it’s worth a try: (Relevance Options -> Sort results by relevance)

    – Enable fulltext search – this option is is mainly for big databases. It’s worth a try. (You can find it under the Fulltext Search settings submenu)

    One or a combination of these options will definitely make a difference. Thank you for the login details, I haven’t used them yet. Let me know if these options make any difference.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.