Bug: Show more results url

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Bug: Show more results url

This topic contains 7 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #39068
    montensiscapital
    montensiscapital
    Participant

    Hi,

    I think I found a bug for the settings for Show more results url (layout Options > Highlighter and Load more features > More results text and behavior.

    The filled out custom url is not being taken in the frontend. The href of the anchor stays empty.

    Scenario:
    – We have one search active and is presented on this page on the right side: https://hrcommunity.nl/vacatures/
    – Select one of the most used phrases “Amsterdam” for example, the asp_showmore button appears, but href is empty

    With thanks,
    Demian

    #39070
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Demian,

    Thank you for the details. I tried to log-in to check the configuration, but the account does not have privileges to view the plugin settings. Can you please check?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39085
    montensiscapital
    montensiscapital
    Participant

    Hi Ernest,

    Correct. I have updated this. Apologies.

    Demian

    #39089
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you very much!

    I removed the base URL from the input, now it seems to be working all right: https://i.imgur.com/psY0O7F.png
    I will check this on our local test servers, it should have worked with your original configuration as well, it is very likely an unknown bug yet.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39091
    montensiscapital
    montensiscapital
    Participant

    Hi Ernest,

    Why do you think this is working? Did you check the frontend? https://snipboard.io/vSgUNB.jpg (https://hrcommunity.nl/vacatures/)

    With thanks,
    Demian

    #39092
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Because I have clicked the link on the front-end, and it is working. The web inspector will not display the “href” attribute, because the click is controlled via javascript.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39093
    montensiscapital
    montensiscapital
    Participant

    Aha! I think this also explains why it did not work with me (I tried multiple things with the url – with and without the base domain). There was probably cache with Javascript, which I had to clear.

    One other question, is there a way make {phrase} work into this box? https://snipboard.io/j6FybX.jpg

    With thanks,
    Demian

    #39112
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    No problem 🙂

    Well, with that it is not possible to use at the moment. However I can probably make it work for the upcoming release, it should not be too difficult.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.