Cant get it to work

This topic contains 5 replies, has 2 voices, and was last updated by

 
Participant
6 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6777

    Participant

    Hello

    I just cant get this to work.
    I have tried everything, looked through the knowledge base, and am still having no luck.
    I’m sure its something I have enabled etc, but there are just so many options and fields in the back end that I cant find the problem.

    I have the search bar set up on this temp page:
    http://southernofficespace.com/home-2-2/

    I try to search the term “Nashville” as I know this is an active page, but nothing comes up and the circle just spins forever.

    Please help me.

    Thanks
    Brett

    #6778

    Hi!

    If you had a previous version installed before, make sure to follow the important update notes.

    I can see the following error message in the console:

    Warning: Illegal string offset ‘image_cropping’ in /home/south194/public_html/wp-content/plugins/ajax-search-pro/search.php on line 108

    which indicates a data inconsistency, which usually happens if the plugin is updated by only overwriting the files. To fix this issue, open the Cache Settings submenu and just save it without chaning anything. That should get rid off the problem.

    If the problem still persists, please add temporary admin and FTP access details to this ticket, and I will debug the code to see what’s causing it.
    To safely add the details you can edit your initial post in this thread, or upload a .txt file attachment. Both methods are safe and visible to only me and you.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6809

    Participant

    That seems to have worked. Thanks!

    Now, How do I make the “auto complete and suggestions” work faster?
    If you got to http://southernofficespace.com/home-2-2/ and type “Nashville” in search box, you will see that it is very slow.
    Also, how do I make it so there is just one line of text with the page title in the drop down? At the moment each result is in a box.
    Im wanting the search box to be just like this – http://www.searchofficespace.com/ – in design, speed and efficiency.

    Again, I am a newbie at all this and not a coder, so very detailed info is greatly appreciated.

    Thanks so much!!

    Brett

    #6810

    Participant

    Nevermind, I fixed the line height by switching it to auto.

    Last thing:
    Why is there a gap under the red “search” button between the button and the box border, and why is the word “Search” not centered properly?

    http://southernofficespace.com/home-2-2/

    How do I fix these?

    Thanks
    Brett

    #6811

    You are welcome!

    The speed of the search is almost entirely dependent on your WordPress setup and server speed. Because of how WordPress is buitl there is also a huge amount of overhead with ever ajax request. In most cases the plugin does the work in less than 0.1 seconds, but it has to wait for it’s turn in the WordPress ajax handler process, and other plugins might (and they do) be initialized, and that’s what takes so long.
    There is unfortunately no way of avoiding it, but there are practices to make it faster. There is an entire chapter in the documentation I recommend reading, it explains almost everything. This sub-chapter might be interesting for you.

    The http://www.searchofficespace.com/ website is not running a wordpress installation, and the search engine is built and optimized only for that exact project. I’m afraid that the only way to achieve that design speed and efficiency is to build a customized search engine for that exact purpose. It also depends on the server architecture. If they are running a Dedicated high end server with multiple layers of caching, then well it’s hard to match that.

    The gap is caused by a missing icon. In the recent update I’ve removed some of the depricated graphics from very early versions. If you go to the Theme Options -> Settings icon & Dropdown menu, you can select one from the new list, and then it will appear.
    Or if you don’t wish to use it, you can disable it entirely on the Frontend search settings -> General panel with the Show search settings switch on the frontend? option.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6861

    Participant

    Thanks for the detailed response.
    I will look into all of this tonight and let you know if I have any further questions.

    Thanks again!
    Brett

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.