Can't search again on mobile after clicking reset icon

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Can't search again on mobile after clicking reset icon

This topic contains 2 replies, has 2 voices, and was last updated by Devonchurch85 Devonchurch85 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #25576
    Devonchurch85
    Devonchurch85
    Participant

    Hi Ernest.

    I’m experiencing another small issue on this page: https://dcl.reeskenyondesign.co.uk/website-search/

    I have a mobile version of ASP configured that only displays at 680px and below. It’s shortcode is [wd_asp id=2]

    The problem is that I carry out a search say for “church”. Great, it works beautifully! I then click the reset cross button (next to the search icon). I enter another search term, say “glass” then the results display briefly and are then hidden. Almost like a z-index issue. Then further searches don’t display anything at all.

    If you don’t reset and search again but deleting the text and entering the new search term it seems to work.

    I’m using an iPhone 6s and have tested in Chrome and Safari which is where the issue is.

    I’ve tested this in Chrome responsive mode on my Mac and the problem doesn’t occur – only on Apple mobile.

    Also tested on my Sony Xperia android phone in chrome and the problem doesn’t occur.

    i thought about using a display:none !important on the reset button but I see it’s dynamic so probably wouldn’t work.

    Hope you can help here.

    Thanks,
    Rees.

    #25586
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Rees,

    Thank you for reporting the issue.

    I only had an iphone SE at disposal at the moment, but I was not able to replicate the issue unfortunately. I also tried browserstack for a real-time 6S emulator, but no luck either: https://youtu.be/vgZ-QjeLFkk

    Did a bit of investigation in the code as well, but I am not sure what might be the cause, and why I cannot replicate it. Can you try clearing the phone browser cache, maybe updating if neccessary?
    I have no clue yet, what the issue is unfortunately.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25610
    Devonchurch85
    Devonchurch85
    Participant

    Hi Ernest.

    My client has an iPhone SE so I’ll ask him to test it. Could be my cache as you suggest.

    I’ll let you know.

    I did clear my cache in Safari on my iPhone but the problem is still there. I also tried moving the shortcode into the tinymce editor but it had no effect sadly.

    Thanks,
    Rees.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.