Can't see display ajax search after click Refine button

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Can't see display ajax search after click Refine button

This topic contains 10 replies, has 2 voices, and was last updated by num919za num919za 7 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #5316
    num919za
    num919za
    Participant

    Button will display in max-width 800px open by model Create By Avada Theme .So when i click button and try to search. I can’t see result display in model. But in display more 800px on sidebar can see result in Ajax Search. I think about Z-index between model and Ajax Search and i so try to change css style.But I can’t see right name class to change Z-index. And I hope you can fix it for me for this problem.

    Thank you.

    Attachments:
    You must be logged in to view attached files.
    #5319
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I can’t see the search anywhere on your site. Could you please send an url where it’s visible?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5320
    num919za
    num919za
    Participant

    Button will display in max-width 800px.

    Pls resize window browser to Bebow 800px You will see Refine Button On Right-Bottom Conner. I setting display for Tablet and mobile

    Sorry

    #5321
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thanks. I just checked the ajax response, but there it’s halted with the following error:

    Fatal error: Call to undefined method YITH_Woocompare_Admin::list_products_html() in /home/handlef/public_html/wp-content/plugins/yith-woocommerce-compare/widgets/class.yith-woocompare-widget.php on line 41

    It looks like it’s coming from the “yith-woocommerce-compare” plugin. It triggers a fatal error, which causes the ajax request to fail. There is a good chance that every other ajax request is halted with the same error, it’s no good.
    Please contact the plugin developer with this issue. In the meantime try to de-activate that plugin.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5322
    num919za
    num919za
    Participant

    sorry Im Test for you instruction.I deactived Compare Plugin.So It Bug Like old problem.

    What Happen now!

    When I type Animatio.n It! Just like display But Not!
    i suggest div to display is display behind model pop-up
    how about Z-index?
    If you try to do. you will understand what Wrong.

    Attachments:
    You must be logged in to view attached files.
    #5324
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Yes, it was a z-index issue.

    Try to use the following custom CSS:

    
    div[id*='ajaxsearchprores'] {
      z-index: 99999 !important;
    }
    
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5325
    num919za
    num919za
    Participant

    sorry.I try for you instruction.I add copy code on ajax theme option in custom css.But does’nt resolve

    Copy code like this

    div[id*=’ajaxsearchprores’] {
    z-index: 99999 !important;
    }

    You can see where Iam Add copy code

    I’dont know where to fix.

    Pls

    Attachments:
    You must be logged in to view attached files.
    #5327
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It’s working for me. I logged in, temporary deactivated the Yith WooCommerce Compare plugin, tried the search, and the results were visible. Maybe it’s your browser cache.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5330
    num919za
    num919za
    Participant

    Hi

    -It work! And I have few question to ask you

    1.But I can’t click to search filter What about css code Pls give me more

    2.And about Fatal error: Call to undefined method YITH_Woocompare_Admin::list_products_html() in /home/handlef/public_html/wp-content/plugins/yith-woocommerce-compare/widgets/class.yith-woocompare-widget.php on line 41

    2.I try to active compare plugin.And Ajax Search can work normally. If I Let it go these error Can you help me? what next affect about my website if don’t contact developer. because Plugin Compare is a free version 🙂

    3.How to Change search old version on a Avada Theme To Ajax Search How to Code it Or setting. I don’t have knowledge about code. And i don’t understand for you short code such

    Simple shortcodes , Result shortcodes , Settings shortcodes , Two Column Shortcode , Extra Parameters

    I try to add in php file on a header.php and search.php

    how to add php shortcode to .php file

    Sorry to more question. Thank you

    Attachments:
    You must be logged in to view attached files.
    #5343
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    1. To fix the settings box, use this:

    
    div[id*='ajaxsearchprosettings'] {
        z-index: 999999 !important;
    }
    

    2-3.
    I have changed the ajax handler on the compatibility option of the plugin, and it seems to have fixed it temporary. You might need to clear your browser cache to see the change.

    It’s hard to tell what can be affected, but you should definitely report this issue to the plugin author so he fixes it for the upcoming updates. You can try to use the

    4. For more information about the shortcodes, please check these chapters from the documentation:

    I have no idea where to put them to be honest. Every theme is very different in therms of code. The best option is to ask the theme author. They usually know the best which files and how you have to edit them.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5369
    num919za
    num919za
    Participant

    It work!

    thank you for Support.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.