Category filter not working

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Category filter not working

This topic contains 15 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 4 years, 6 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #15753
    mbansal131
    mbansal131
    Participant

    Hi,

    I am trying to use the “Category & Taxonomy Terms” filter on this page –>

    http://britishhapur.top/veeba/recipes/

    For testing purpose, I have added One category (Mint Mayonnaise) to a single post –>

    http://britishhapur.top/veeba/recipes/paneer-roll-recipe/

    Now on front end when i use the category filter, instead of displaying only 1 result (Paneer Roll Recipe) it is displaying multiple/all results.

    #15755
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    By default the plugin will display items that does not have any term from the selected taxonomy. In this case, if the other items have no categories, they will be included – as in most cases this is expected.

    I have turned that option off for you on the Frontend search settings -> Advanced panel: https://i.imgur.com/ESaRkSB.png
    I also noticed that you had an category inclusion set to include items from ‘Recipes’ category as well, so it was also including those items. I have disabled that too. In this case, I recommend rather excluding items by categories, which you don’t need: https://i.imgur.com/PR4idCX.png

    Now if you select the category, only items from that will be displayed.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #15765
    mbansal131
    mbansal131
    Participant

    HI, Thanks.

    Is there a way to display results only from “Post Titles”

    And not from the content inside posts ?

    Thanks

    #15766
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Sure, you can change that on the General Options -> Sources panel: https://i.imgur.com/PgULAkV.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #15769
    mbansal131
    mbansal131
    Participant

    Oh Great, works Thanks!

    #15770
    mbansal131
    mbansal131
    Participant

    Also is there a way to have a “Clear all filters” button or a way in which all filters will automatically reset after we perform a second search.

    #15774
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    You are welcome. Unfortunately that is not yet possible, the filters only reset if the page is reloaded.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #15775
    mbansal131
    mbansal131
    Participant

    OK and lastly how to remove the “Did you Mean: suggestions” ?
    I have removed the Text but the suggestions still show up.

    Thanks.

    #15778
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Under the Autocomplete & Suggestions -> Keyword suggestion panel: https://i.imgur.com/tf1Z4Ys.png

    Autocomplete and Keyword suggestions documentation

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #15779
    mbansal131
    mbansal131
    Participant

    Oh sorry, all these options are right under my nose, but somehow i miss them.

    Anyway thanks for the great & prompt support!

    #15780
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #15842
    mbansal131
    mbansal131
    Participant
    You cannot access this content.
    #15843
    mbansal131
    mbansal131
    Participant
    You cannot access this content.
    #15850
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the details! I just looked from a mobile view, but it looks correct to me on the front-page: https://i.imgur.com/yhefMQv.png
    I have also tried on two separate phones to make sure.

    Is this been resolved, or is it still present somewhere? Let me know.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #15853
    mbansal131
    mbansal131
    Participant

    Its been resolved. Actually the shortcode on the slider revolution was creating problems. So i inserted search shirtcode separately below the slider so works great now! thanks !

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.