Category & Taxonomy terms | Result not correct, show all posts

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Category & Taxonomy terms | Result not correct, show all posts

This topic contains 5 replies, has 2 voices, and was last updated by

 
Keymaster
2 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25037

    Participant

    Hi,

    Thanks for this great plugin!

    Everything works very well EXCEPT … the taxonomies filter.
    I’ve created 1 category and 2 separate taxonomies: “Vacature Type” and “Locatie”.

    “Categorie” contains the values:
    – Accountancy
    – Audit en assurance
    – Controlling & reporting
    -Credit maangement

    “Vacature type” contains the values:
    – Deeltijds
    – Freelance
    – Voltijds

    “Locatie” contains the values:
    – Antwerpen
    – Borgloon
    – Brussel
    – Hasselt

    I’m having a hard time getting my taxonomy filters to work properly..
    Each taxonomy has a separate dropdown box where I can select a specific value.
    e.g. when I want to show only the posts where “Vacature Type” = “Voltijds” the result is that I get a list of all the posts

    When I do the same for “Categorie” = “Accountancy” then I get a correct result.
    I’ve tried different settings but can’t get this to work.

    You can try this out at https://www.christimmermans.com/finvision2/nl/jobs-berichten3

    Could you help me out please and tell me what I’m doing wrong?

    Thank you so much!

    Kind regards,
    Chris

    #25044

    Hi Chris,

    Thank you very much for your kind words!

    I suspect, that those results are probably items, that does not have the “job_type” taxonomy related to them – and by default the plugin displays results, that does not have a relationship with a filtered taxonomy.
    Changing this option should resolve the issue: https://i.imgur.com/x60BglT.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25052

    Participant

    Hi Ernest,

    Thank you for the fast reply.

    Changing the option still didn’t give the expected results.
    I’ll give an example to clarify everything.

    I have the following posts:
    ————————————

    Postname: ICT tester
    Categorie: Fin management
    Job Locatie: Hasselt
    Vacature Type: Voltijds

    Postname: ICT auditor
    Categorie: Audit and assurance
    Job Locatie: Hasselt
    Vacature Type: Freelance

    Postname: ICT operator
    Categorie: Controlling and reporting
    Job Locatie: Hasselt, Antwerpen
    Vacature Type: Freelance

    Expected results with the frontend filter ( where I have 3 dropdown lists):
    —————————————————————————————————

    CASE 1
    ======

    Action:
    In the filter, in the ’Job Locatie’ dropdown list, I select ’Antwerpen’
    In the other dropdown lists, I select “Toon alles”
    (“Toon alles” is dutch for “Display All”)

    Expected result:
    A list of posts where ‘Job Locatie’ = ‘Antwerpen’

    Result: shows everything or shows nothing at all (depending on settings in “Show posts/CPM …)

    CASE 2
    ======

    Action:
    In the filter, in the ’Vacature Type ’ dropdown list, I select ’Freelance’

    Expected result:
    A list of posts where ‘Vacature Type’ = ‘Freelance’

    Result: shows everything or shows nothing at all (depending on settings in “Show posts/CPM …)

    See also the attachment ‘screenshots” I provided.

    In short:
    ———-

    When I select a value in an individual dropdown list, and I leave the other dropdown lists alone (set to”Display All”)
    it should show me the posts where the condition is true for selected dropdown lists (value different from “Display All”).

    And for some reason this won’t work 🙁

    Best regards,
    Chris

    Attachments:
    You must be logged in to view attached files.
    #25057

    Hi,

    Thank you for the details! I have logged in to test the problem directly, and I think I have found it. All it was, that the wrong taxonomies were used, with similar names: https://i.imgur.com/TwJn4eT.png
    I have changed that, now I think it should be okay.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25061

    Participant

    Hi Ernest,

    I feel so stupid, how could I not have seen this 🙁

    Anyway, thank you so much for your help, you made my day 🙂

    Kind regards,
    Chris

    #25062
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.