Checkbox category selectors not applying/working

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Checkbox category selectors not applying/working

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 3 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #19851
    custompczone
    custompczone
    Participant

    I have a search bar that contains two check boxes for post categories. I’m realizing now that the checkboxes don’t actually do anything. They aren’t filtering by category and they aren’t really limiting the search at all, whether checked or not. I attached images of what happens when I uncheck both boxes and search for something. I assume nothing should come up if it is working properly. Am I missing a step here?

    Attachments:
    You must be logged in to view attached files.
    #19856
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I can’t tell only by a screenshot, but it is very likely, that you are seeing items, that are not affected by the checkboxes (does not belong to any category within the filter).
    In that case, try the following setup: https://i.imgur.com/rD5iKsX.png

    You can also experiment with options 1 and 2, but based just on your screenshot, that is probably the optimal setup. For more information on how those logics work, you can check this documentation section.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #19862
    custompczone
    custompczone
    Participant

    Thank you, I was able to solve the issue with results showing up with no boxes checked. Now the second issue is that one of the selectors doesn’t work properly. When I check ‘premium trades’ and not signals, it works fine and no signals show up. But when I check ‘signals’ and not ‘premium trades’, both categories of posts show up

    #19864
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    When checking ‘signals’ only:
    – Are the results displayed within any other categories?
    – or are the results within both categories?
    – or are these results within none of the categories?
    – Do you have by any chance category inclusions/exclusions set under the Advanced Options -> Exclude results panel? That overrides the filters.

    Can you please add temporary back-end access, so I can take a look at this? Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.