Conflict with QTranslate-X

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Conflict with QTranslate-X

This topic contains 15 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 6 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #6339
    sendohzk
    sendohzk
    Participant

    After installing and activating the plugin, no results was found for any search at all. I’m using the the qtranslate-x plugin. I’ve looked through the support forum and it seems that a slight modification is required for qtranslate-x work with your plugin. Please advise. Thanks.

    – Zhi Kai

    • This topic was modified 6 years, 9 months ago by sendohzk sendohzk.
    #6344
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    No changes are required whatsoever. I just tested the plugin with the latest version of Qtranslate X and it’s working on my test servers without issues.

    Make sure you have the compatibility functions enabled on the Qtranslate X integration tab: https://i.imgur.com/AQLcSIP.png

    A few more questions:

    • Does the results start appearing if the Qtranslate X is disabled? If not, then it’s most likely a plugin configuration issue.
    • Are there any error messages displayed on the back-end or the front end?
    • What type of content are you searching? (posts, pages, products, categories or tags, maybe attachments, etc..?)

    Can you also provide temporary admin and FTP details so I can check on the problem and debug the code directly?

    To safely add the details you can edit your initial post in this thread, or upload a .txt file attachment. Both methods are safe and visible to only me and you.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6368
    sendohzk
    sendohzk
    Participant

    I’m not able to provide temporary admin or FTP. Will you be able to provide some instructions for me to debug?

    I’ve already deactivated all plugin, changed the theme to twentyfifteen but search is still not working. It does show “No Results” and if I enable redirecting to a result page, results are shown. But no result is show if I want it to return the result via AJAX. I’ve also turned an the compatibility functions as mentioned by you.

    I’m searching a custom post type created by my theme. I’ve attached my theme files below. Thanks.

    Attachments:
    You must be logged in to view attached files.
    #6370
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    In that case can you please go to the Import/Export menu and export all your search instances? I will import them and check the search options.

    Please copy the exported contents to a .txt file, do not paste it here directly (lot’s of content).

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6388
    sendohzk
    sendohzk
    Participant

    Attached. Thank you.

    Attachments:
    You must be logged in to view attached files.
    #6391
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Everything looks fine to me on the configuration. I’m getting results.

    One thing though: on the General Options -> Behavior panel the Show exact matches only? option is enabled. Can you please try turning it off and trying it again? Exact matches will only match multiple keywords if they are in the exact order in the text.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6395
    sendohzk
    sendohzk
    Participant

    I’ve submitted the admin access. Please do take a look. Thanks a lot.

    #6396
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thanks, but can you also link me to a page where the search is active? I cannot see it anywhere.

    And please can you enable the debug mode in the wp-config.php file, to see if there are any error messages supressed.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6399
    sendohzk
    sendohzk
    Participant

    You can try this page: http://staging.bwm.org.sg/en/guang-lun/%E7%AC%AC%E4%B8%80%E7%99%BE%E5%8D%B7-b%E9%9D%A2/ .

    All the posts (post type = sermon) are in Chinese. You can just try to search for the title which is in Chinese.

    I will try to turn on debug mode as there is currently some issues with the FTP.

    #6400
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thanks! I see an error 500 at the ajax response with no error message. It can be anything. Let me know if you can turn on error reporting or provide temporary FTP, and I will check again 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6412
    sendohzk
    sendohzk
    Participant

    I’ve switched on Debug mode. Thanks.

    #6413
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I’m getting a 404 default server error pages on the URLs provided. I’m guessing you are moving/changing things: https://i.imgur.com/xOXQFZK.png

    Let me know when it’s finished and I will try again.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6428
    sendohzk
    sendohzk
    Participant

    Do try again. Thanks.

    #6429
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for enabling the debug, I can already see the problem. I’m getting this error:

    Call to undefined function mb_strtolower() in ....

    This means, that multibyte string functions are disabled on your server. I can suggest 2 possible solution to this issue:

    1. Enabling multibyte string (mbstring) module – It’s widely used, many plugins are using these functions, and are very helpful. Especially in your case – whereas your language does indeed use multibyte strings. Here are some guides how you can enable mbstring in your php.ini file:

    How to enable mbstring?

    If you don’t know how to make these changes, please contact your server administrator.

    2. Turning off the Display the description context? option on the Layout Options -> Results layout panel: https://i.imgur.com/HMNgVG1.png

    This way you bypass the code conducting the error.

    Let me know if any of this helped.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6430
    sendohzk
    sendohzk
    Participant

    Thanks for the help. I will be switching my web host soon, thus will only be making the changes with the new web host. By the way, your support is really awesome. I’ve just given the plugin a 5 stars rating in Themeforest.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.