Create Search Instace – New instance no show

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Create Search Instace – New instance no show

This topic contains 2 replies, has 2 voices, and was last updated by

 
Participant
6 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6851

    Participant

    Hi!
    I first ran a testrun of this amazing plugin localy on my computer using MAMP.
    It was a blast!

    Getting it to work on the intended WP-account however proved difficult.

    I installed the plugin 4.5.5. on my WP-account (version: 4.3.1–sv_SE)
    No problems there…

    But when i created the Search Instance id cleared (search form sucssesfully addad) but it was no where to be seen???

    The error check cleared!
    But when clicking Index Table i gett this message: The index table does not exist and cannot be created. Please contact support.

    Any ideas??

    Regards Andreas

    Attachments:
    You must be logged in to view attached files.
    #6853

    Hi!

    It seems like your database account (or wordpress) does not have sufficient privileges to create database tables. The reason why you don’t see the search instance, it’s because the neccessary tables are missing, which should have been created when you activated the plugin.

    You have few options here:

    1. Create the tables manually. I suggest exporting the database tables from your local MAMP installation and importing them on your server via PHPMyAdmin (or your prefered tool). The plugin uses the following tables: wp_ajaxsearchpro, wp_ajaxsearchpro_priorities, wp_ajaxsearchpro_statistics, wp_asp_index

    2. Checking and fixing the database user permissions in your CPANEL. I highly recommend doing this, as many plugins need permissions to create database tables. Then reinstalling the plugin should solve the problem.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6869

    Participant

    Fantastic!
    You where ofcourse right 🙂
    I now have all the permissions needed.

    Thank you so much!

    Cheers / Andreas

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.