creating index table

This topic contains 4 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 2 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25015
    Maxim73
    Maxim73
    Participant

    Hi, I’m trying to create index table and first the creating process goes quite fast but then it slow down … almost stop. +1% progress will take for ~1 hour

    Have a look https://prnt.sc/qa87ee

    I try to do it few times but the result the same 🙁

    i lowered Post limit per iteration to 10 – it doesn’t help too.

    The server quire fast and the site works good, but i just want to increase speed of the search via index table because the number of posts will be
    about 5-6 millions soon.

    What can I do?

    #25016
    Maxim73
    Maxim73
    Participant

    I have set up cron job and as i can see there is some progress in creating index table. I run the cron every 2 minutes …

    #25027
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I would rather recommend increasing the post limit per iteration to a much higher number, say 200 first. Then if your server can handle that, it will be much faster. If there is a failure, the plugin will try to lower that automatically during the indexing, it will also notice you if the process fails many times, then you should start lowering that value.
    If you have attachments to index, then those are indexed one-by-one regardless, as that is a very CPU heavy process.

    The problem with the cron job is, that WordPress cron is not actually a classic cron job, it is triggered only whenever a page is opened and WP itself loads. That will not help much in this case.

    I also recommend having the window visible on your desktop while indexing, Chrome and Firefox are known for throttling the javascript when a tab is not visible, and may delay the triggers.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25032
    Maxim73
    Maxim73
    Participant

    Ernest, thanks.
    We blocked Cron from working with “define(‘DISABLE_WP_CRON’, true);” in wp-config.php and run tasks using WP-CLI (wp cron event run –due-now). Is there a way to completely turn off the start of indexing when going to your plugin’s “asp_index_table” page because it hangs anyway? We gonna have several million posts on the site, so we can’t handle cron tasks on the frontend.
    Thanks!
    Max.

    #25042
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.