Custom Post Type Displaying Weird Description

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Custom Post Type Displaying Weird Description

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #41414
    dennis_airbase
    dennis_airbase
    Participant

    Hey there – the majority of our search results are referencing our SEO title and description custom fields.
    _aioseo_title
    _aioseo_description

    There are a couple of custom post types/ specific pieces of content that aren’t displaying the meta description. Instead, they are displaying weird characters and symbols. I looked at those specific pages and they all have standard meta descriptions populated.

    Any advice? If you want to test you can use the search on http://www.airbase.com
    try searching “definitive” and you will see weird descriptions.

    Any help is greatly appreciated.

    Attachments:
    You must be logged in to view attached files.
    #41426
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Unfortunately the results page contents printed are not affected by Ajax Search Pro, that is a theme controlled feature. Most themes use the the_excerpt() function to print the post excerpts on the results pages. The weir symbols you see there is an automatically generated excerpt, which contains parts of a non-executed shortcode for some sort of social icons snippet.

    I recommend checking your theme options, some themes have options to change what field is displayed on the results loop. You can also ask the theme author on how to change that, usually it is very simple.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.