Customise Menu Search Bar

This topic contains 10 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 3 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #47069
    mk3
    mk3
    Participant

    Hello,
    I would like to customise a couple things with the search bar in the menu.

    Firstly, I would like the background of the menu bar to be transparent and not black – when I try to change that in customisation options, it wont accept completely transparent.

    Also, is there a way to make the search bar expand to a floating bar for example just below it instead of pushing the other menu options?

    Thansk!

    Regards – Matt

    #47073
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Matt,

    Thank you for the details!

    Right now it looks like the icon background is black, you can change that here: https://i.imgur.com/FqcroRf.png

    As for the expansion, that is also possible, try like this: https://i.imgur.com/zJ8WRuO.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #47075
    mk3
    mk3
    Participant
    You cannot access this content.
    #47076
    mk3
    mk3
    Participant

    Also, I’m having trouble centrally horizontally aligning the search icon with the rest of the menu bar – would you have suggestions for that too?

    Thanks!

    Attachments:
    You must be logged in to view attached files.
    #47083
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Sure!

    Can you please also check the overall box background: https://i.imgur.com/2rBdI4L.png
    That is behind the icons, so that could explain the color.

    For the alignment, try aligning all the menu items to the middle, as right now everything is on the baseline:

    .header-nav li {
        vertical-align: middle;
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #47151
    mk3
    mk3
    Participant
    You cannot access this content.
    #47157
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Sure!

    Can you please check if this option is also enabled: https://i.imgur.com/HkzCrGG.png
    It should be ON by default, but just to make sure. Another common issue is that the imagick policy does not have the PDF allowed.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #47161
    mk3
    mk3
    Participant
    You cannot access this content.
    #47163
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    The alternative image source 2 is the problem there, it’s set to a page screenshot, which is always going to be there, and because the image is not empty, it will never fetch the PDF images.

    Use this setup:
    – Primary: Featured
    – Alt 1: Post Content
    – Alt 2: Default
    – Alt 3: Disabled
    – Alt 4: Disabled

    That should do the trick.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #47228
    mk3
    mk3
    Participant
    You cannot access this content.
    #47235
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.