Deferred Javascript not working with WP Rocket

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Deferred Javascript not working with WP Rocket

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #34014
    alfresco9989
    alfresco9989
    Participant

    Hi Ernest,

    I haven’t been able to get live search working with WP Rocket since I changed my site to Elementor.

    It used to work when I found your help on putting “/ajax-search-pro/js/*” in the WP Rocket exclusion for Load JavaScript Deferred, but now it won’t work, and has reverted to previous behaviour of only working for a logged in user.

    I just renewed my support for your great plug-in, and I hope can solve this for me, I’d be most appreciative.

    I get much better Lighthouse scores when this option is enabled.

    Also, I have country blocking enabled on my CloudFlare firewall, as well as other restrictions via plug-ins on the site. If you can, please connect via VPN in the Australia region. Otherwise, please let me know what country you will be connecting from and I will allow that through the firewall.

    Best regards,
    Mike

    #34015
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Sure, I will try it, maybe I can see something on the error console. However I can not guarantee anything, since the WP Rocket plugin is the one tempering with the document flow.

    I tried to log-in with the details to the back-end, but it says the password is incorrect. Can you please check?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34017
    alfresco9989
    alfresco9989
    Participant
    You cannot access this content.
    #34018
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thanks!

    I found the issue and a solution as well. The deferred jQuery script was causing the issues, some scripts were reporting errors due to that. I have excluded them: https://i.imgur.com/1qupfIh.png
    It should work all right now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34019
    alfresco9989
    alfresco9989
    Participant

    Ernest, thanks so very much!

    Yes, seems to be working properly.

    Could you kindly let me know which plugin(s) the scripts belong to, if that’s not too much trouble?

    All the best,
    Mike

    #34020
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Sure 🙂 Both scripts are coming from the WordPress core, used by most of the plugins.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.