Draft posts in the search results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Draft posts in the search results

This topic contains 8 replies, has 2 voices, and was last updated by Karsten Windfelder Karsten Windfelder 5 years ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13767
    Karsten Windfelder
    Karsten Windfelder
    Participant

    Hi Ernest,

    how can I get rid of showing draft posts in search results?

    Thx,
    Karsten

    #13769
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Karsten,

    Deleted posts should not show up in the search results at all. Make sure to clear your site cache if you have any, just in case.
    If you want, I can take a look at the issue, feel free to post FTP and back-end details as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13770
    Karsten Windfelder
    Karsten Windfelder
    Participant

    I´m sorry Ernest, I was editing my question seconds later…

    The drafts are in the search results.

    #13771
    Karsten Windfelder
    Karsten Windfelder
    Participant

    Here is a screenshot

    Attachments:
    You must be logged in to view attached files.
    #13774
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I’m not able to re-create that either on my test environment, it might be something specific.
    If you want, I can take a look at the issue, feel free to post FTP and back-end details as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13775
    Karsten Windfelder
    Karsten Windfelder
    Participant
    You cannot access this content.
    #13776
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you!

    I’m not sure, but I guess this is going to be something to do with the multisite environment. I believe the index table options are somehow not correctly parsed whenever saving a post.

    Can you please also add temporary (s)FTP details? I would like to debug through the search code, and maybe create a temporary test draft post to see why the options are not loaded correctly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13777
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I believe I might have found the problem in one of the plugin files, I don’t think I need the FTP access at all.

    To fix the issue, please replace the file contens in wp-content\plugins\ajax-search-pro\includes\classes\actions\class-asp-indextable.php with this: https://gist.githubusercontent.com/anag0/25d119fb40fd1a4ea3d44b6e82822416/raw/5cb9e43bb5bae759ccf5bc10180c638c1f151095/class-asp-indextable.php

    After that, make sure to re-create the index table under the Index table options submenu. That should solve the issue permanently. I will also make sure to include this fix in the next release.

    PS: please have a back-up of everything, before making any direct changes.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13779
    Karsten Windfelder
    Karsten Windfelder
    Participant

    Hi,

    great, looks good.

    Still indexing, but I think that worked 🙂

    Greetings from Canada
    Karsten

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.