Display Problem

This topic contains 10 replies, has 2 voices, and was last updated by

 
Participant
7 years, 11 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1022

    Participant

    Hi,

    I have a problem with the display of the search bar.

    I have attached a screenshot of what is happening.

    Thank you

    • This topic was modified 7 years, 11 months ago by  asd.
    Attachments:
    You must be logged in to view attached files.
    #1024

    Hi!

    This is most likely because the css files are not writeable. Make sure you chmod the plugins/ajax-search-pro/css directory to 777.

    Alternatively you can enable inline styles on the “compatibility settings” tab. It should solve the issue right away 🙂 It’s available from version 2.1, which was uploaded to codecanyon 2 days ago.

    Let me know how it goes!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1033

    Participant

    Hi!

    Thank you for your answer, sadly, I already gave the 777 rights recursively for the css and cache folder.

    I tried to enable inline styles on the compatibility settings too. Nothing changed.

    I noticed that the [wpdreams_ajaxsearchpro id=1] is working, but not the other one…

    Thank you.

    #1034

    Do you have the same search shortcode ( [wpdreams_ajaxsearchpro id=1] ) twice on one page? Because it wont work that way.

    If not, then can you give me an url to your website with a possible temp admin/ftp access? I want to check this out. Judging by the screenshots the stylesheet is not loaded, or haven’t been saved somehow.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1036

    Participant

    No we don’t have it twice at any time.

    The page from the screenshot is http://www.url.com/test

    I added the temp information for you to log on.
    The path is /var/www/html

    Thank you

    #1037

    Okay. Something isn’t right. On the top right section there is a very old version of the ajax search pro, was it included in the template?

    I tried to switch the template to the default and the search was showing/working on url.com/test page. So the template is breaking it for sure. You should try to disable the old version from the template and it should work fine 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1038

    Participant

    Okay, thank you very much for pointing this out!
    You are right, it was included in the theme.

    We will fix this.

    Best regards!

    • This reply was modified 7 years, 11 months ago by  asd.
    #1040

    Participant

    Can I ask you how you saw that it’s an old version ?
    That’s strange because we uploaded the version from 2 days ago.

    #1041

    The stylesheet was embedded into the template itself, it was not coming from the plugin. That is not how it should be.

    Anyways I might figured out what is causing the issue. There is one functions that prints the stylesheets to the header, I think that might be blocked by an action or filter in the template.

    I cant edit the files however with the ftp account nor the admin account you provided. Can you please upgrade the temp ftp account to make me able to modify the search files?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1042

    I got it!

    Dont need ftp 🙂

    Remove the lines 1218-1220 from wp-content/themes/lybacitheme/functions.php

    if (!is_admin()) {
    	remove_action('wp_print_styles', 'search_stylesheets');
    }

    That should solve the issue right away. 🙂 That’s what has been blocking the plugin stylesheets. Basically it removed the function action as I suspected.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1043

    Participant

    Thank you very much!

    Indeed, it fixed it!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.