Doesn`t work enter button

This topic contains 8 replies, has 2 voices, and was last updated by

 
Keymaster
3 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #16960

    Participant

    Hi Ernest.
    The enter button does not work to start the search.

    Thank you.

    Fernando

    Attachments:
    You must be logged in to view attached files.
    #16969

    Hi Fernando,

    You are right, I believe it is related to the recent update. I have noted this as a bug, and will be resolved within the next release.
    Thank you again!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #16971

    Participant

    Ok Ernest.
    How can i get the previous version? Can you send me?

    Thanks

    #16972

    Participant

    Sorry, one more thing.

    How to configure in index table when searching by attribute, results in products and not the attribute.

    Attached image.

    Thank you

    Fernando

    Attachments:
    You must be logged in to view attached files.
    #16984

    Hi Fernando,

    I don’t recommend going back to an older version, instead I suggest resolving thath with this custom code:

    Add this custom code to the functions.php in your theme/child theme directory (copy from line 3 only!). Before editing, please make sure to have a full site back-up just in case!

    Attribute search
    Some WooCommerce attributes might be taxonomy terms, and others might be custom fields, it depends. On the Index table options panel, make sure to include any taxonomy that might be a product attribute: https://i.imgur.com/h2pazi8.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #16985

    Participant

    Hi Ernest.
    Thanks for the code. I’ll try this weekend.

    The taxonomies are configured.
    The problem is that instead of showing the products with the image, title, etc. As you see in the image if you are looking for sku. It shows the attribute and thus it can not be.

    Attachments:
    You must be logged in to view attached files.
    #16998

    Hi!

    On the search instance options, General Options -> Sources 2 panel, make sure that nothing is selected: https://i.imgur.com/6jmHpJ9.png
    It will stop the categories/attribute taxonomies from showing from the results.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #17007

    Participant

    Hi Ernest.
    I have deleted as you indicate. Now it does not find the attributes and returns “no results”.

    I have to set it up somewhere else?

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #17012

    Hi,

    Those options will only allow the attributes as results.

    You need to select these attributes on the Index Table options submenu: https://i.imgur.com/yBq2E8m.png
    Keep in mind, that the index table will have to be re-created after that, then it should start returning products based on attributes.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.