Dropdown under results – z-index?

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Dropdown under results – z-index?

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 4 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #16963
    Fredag
    Fredag
    Participant

    Hello

    I am developing on localhost. Theme is Divi with childtheme.

    I have a search box in one column and the settings (dropdown with all the categories) in another.
    Below I have the results.

    But the dropdown goes under the results. I am trying to give both the dropdown and the result different z-index but to no avail. Se attached image.

    How can I have the dropdown to be over the results? As it should be.

    /Stefan

    Attachments:
    You must be logged in to view attached files.
    #16970
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Stefan,

    It is actually set higher than the results, it should be displayed over it. The same setup on a test server looks like this on my end: https://i.imgur.com/2LOWJc3.png

    I am guessing, that the issue is the z-index of the parent element. Do you happen to use a page builder of some sort, or any custom code to place the elements like that? If so, then the z-indexes might be set to the same value on those blocks, meaning that the latest rendered block will always float over the preceeding ones. Try looking at the blocks on the builder, it may support changing the z-index values on each block. In HTML the parent z-indexes are always higher priority, so no matter how big the drop-down z-index is set, the parent z-index will always apply.

    If you can link me to a test page where I could see this, I might be able to suggest a custom CSS code to adjust the z-index values correctly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #16976
    Fredag
    Fredag
    Participant

    Tank you for pointing me in the right direction.
    I set the z-index on the first row to 20 (the row/div that contains the search and settings)
    This was done in the Divi-builder (Divi-theme).
    And it worked!

    Thanks again Ernest for the correct and fast answer.

    /Stefan

    #16977
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.