Error on a live website REALLY REALLY urgent!

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Error on a live website REALLY REALLY urgent!

This topic contains 8 replies, has 2 voices, and was last updated by barabasis barabasis 1 year, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #31320
    barabasis
    barabasis
    Participant

    This is on a live website so it is REALLY REALLY urgent!

    Since ajax-search-pro 4.19.4 I can’t update anymore cause my search query returns 0 results.
    I tried upgrading to your new 20.4 hoping you resolved the problem but actually no. And now also the 19.4 gives me problems and I can’t see the search results anymore.

    I installed now 4.20.04 and as you can see I see the attached error.

    This is on a live website so it is REALLY REALLY urgent!

    ps. it’s an NSFW website

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #31321
    barabasis
    barabasis
    Participant
    You cannot access this content.
    #31327
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you for the details, I have moved them to a file, which is not accessible to the public.

    I logged in to check, and interestingly if I switch to the “Regular engine” the search seems to be working. The index table however seems to be perfectly fine as well, so I am not sure. I suspect this is either a custom code conflicting or there is a yet unknown bug.

    Can you please add temporary FTP access, I would like to debug the query.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #31328
    barabasis
    barabasis
    Participant
    You cannot access this content.
    #31425
    barabasis
    barabasis
    Participant

    Hello ernest,

    I am stil waiting for an answer to come from you… did you manage to find the bug on our website?

    Thanks
    kind regards

    #31426
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #31427
    barabasis
    barabasis
    Participant
    You cannot access this content.
    #31434
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    1. That text was already there, it informs you about using the custom ajax handler. It was activated all along. You can completely ignore that message.

    2. I did not change any styling, any custom code nothing. I only made a change in the core search files, which are completely unrelated to the actual search itself. Plus I had to save the option like I did before, nothing else was changed. I suspect this is a cache related issue, CDN or minify caches tend to have a long reload time. I have changed the following options to try bypassing that: https://i.imgur.com/1OZ4bsM.png
    These are the default options, I recommend leaving them as they are. The change should be apparent on the front-end now.

    3. You may have to ask the plugin author about that. I only changed a single line on the core query files, but nothing about display or any other files. I didn’t even notice that plugin until now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #31435
    barabasis
    barabasis
    Participant

    1. right ok
    2. your change actually solved the problem and reverted back as it was indeed
    3. right ok, will do that

    Thanks for your support Ernest
    Enjoy the rest of your day!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.