Exclude from search functionality

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Exclude from search functionality

This topic contains 5 replies, has 2 voices, and was last updated by

 
Keymaster
2 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25290

    Participant

    I would like to like to exclude irrelevant pages from the index by ID. I checked the documentation, but it seems quite outdated and the instructions there do not cover (4.17.2) my version anymore. Furthermore: Does your pro version honour the default wordpress “exclude from search” functionality?

    #25291

    Hi,

    This documentation should be up to date: https://documentation.ajaxsearchpro.com/advanced-options/excluding-and-including-results/exclude-by-item-or-id
    If you scroll down on that page, you should see an exclusion box by ID, as well as a search drag/drop field for easier exclusion.

    Unfortunately there is no “exclude from search” functionality in core wordpress, that is only possible via 3rd party plugins or via custom code, or some themes may also offer an option for that. There are so many different solutions, that we would not be able to reliably support them.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25304

    Participant

    Thanks for your response Ernest,

    A different question popped up now while trying to exclude some pages.

    I excluded search results by ID, but for some reason I still see them in my search results page (not in the dropdown). I also tried using the “drag and drop” feature, not working either. The results I do not want in my search are just pages, so no custom taxonomies or anything special.

    Example: Post: 10321 -> Postname: Test JS CTA Buttons -> Shows on resultpage (not in result dropdown) when query ” inloggen” is entered in searchfield.

    Any advice on what could cause the issue?

    #25308

    Hi,

    My guess would be, that the search override feature is not enabled, that would explain it perfectly. After turning it on, it should resolve the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25311

    Participant

    Thanks again Ernest,

    You’re the greatest!

    #25312
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.